giovedì 27 gennaio 2011

ATI Radeon HD 3450 & Ubuntu Lucid Lynx 10.04

Driver radeon: I'm experiencing a lot of problems with this cheap card

VGA compatible controller: ATI Technologies Inc RV620 LE AGP [Radeon HD 3450]

using the driver radeon on Ubuntu 10.04: inability to use Compiz, slow flash videos, ridicolous performances in general. 
The main cause: KMS.
"Kernel mode-setting (KMS) shifts responsibility for selecting and setting up the graphics mode from X.org to the kernel. When X.org is started, it then detects and uses the mode without any further mode changes. This promises to make booting faster, more graphical, and less flickery."

Solution (for me):
  1. Open /etc/default/grub in a text editor
  2. Replace

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

    with

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=1"

  3. Update grub2: sudo update-grub
  4. Reboot
Note 1: Pay attention to grub2: in my humble opinion it's the worst software I have ever seen on Ubuntu.

Note 2: Not tested yet but the following fix should work fine:

echo options radeon modeset=1 > /etc/modprobe.d/radeon-kms.conf

If so,  don't modify /etc/default/grub.

Driver fglrx:  this fantastic installation guide explains all we need to know about the driver fglrx. I recommend to install the driver manually.

Note: if we installed the driver and, after the reboot, Xserver returns an error like this:

(EE) Can't load FireGL DRM library (libfglrxdrm.so)
(EE) fglrx: Failed to load module "fglrxdrm" 
(module does not exist, 0)
(EE) fglrx(0): Failed to load DRM library
(EE) fglrx(0): Preint failed
(EE) Screen(s) found, but none have a usable configuration.

probably update-alternatives has not created symbolic links to the files in the fglrx directory because the very related gl_conf entry has been set to manual. we have to remove the driver, and change the gl_conf into automatic mode before a new installation with this command:

sudo update-alternatives --auto gl_conf

another lecture of interest about this argument here.

AFAIK, the unique issue for me with this driver regards the bttv driver: if I run tvtime, bttv returns a bunch of these messages:

bttv0: timeout: drop=29 irq=46/104431, risc=3261a4d4,
bits: VSYNC HSYNC OFLOW RISCI

Unloading and reloading bttv is a temporary fix that works for now.

Best regards.